bakefile-0.2.9-r1.ebuild 585 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit python-single-r1 bash-completion-r1
  6. DESCRIPTION="Native makefiles generator"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. HOMEPAGE="http://bakefile.sourceforge.net"
  9. LICENSE="MIT"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="doc"
  13. RDEPEND=""
  14. DEPEND=""
  15. src_install () {
  16. default
  17. if use doc ; then
  18. dohtml -r doc/html/.
  19. fi
  20. # TODO: symlink the two
  21. newbashcomp bash_completion bakefile
  22. newbashcomp bash_completion bakefile_gen
  23. }