bats-0.4.0.ebuild 485 B

123456789101112131415161718192021222324
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="An automated testing system for bash"
  5. HOMEPAGE="https://github.com/sstephenson/bats/"
  6. SRC_URI="https://github.com/sstephenson/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  7. LICENSE="MIT"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. src_test() {
  11. bin/bats --tap test || die "Tests failed"
  12. }
  13. src_install() {
  14. einstalldocs
  15. dobin libexec/*
  16. doman man/bats.1 man/bats.7
  17. }