buildbot-slave-0.8.10.ebuild 1.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit distutils-r1 readme.gentoo systemd user
  6. DESCRIPTION="BuildBot Slave Daemon"
  7. HOMEPAGE="http://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.python.org/pypi/buildbot-slave"
  8. MY_PV="${PV/_p/p}"
  9. MY_P="${PN}-${MY_PV}"
  10. SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
  11. LICENSE="GPL-2"
  12. SLOT="0"
  13. KEYWORDS="~alpha amd64 arm hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux"
  14. IUSE="test"
  15. RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
  16. dev-python/twisted-core[${PYTHON_USEDEP}]"
  17. DEPEND="${RDEPEND}
  18. test? ( dev-python/mock[${PYTHON_USEDEP}] )"
  19. S="${WORKDIR}/${MY_P}"
  20. pkg_setup() {
  21. enewuser buildbot
  22. DOC_CONTENTS="The \"buildbot\" user and the \"buildslave\" init script has been added
  23. to support starting buildslave through Gentoo's init system. To use this,
  24. set up your build slave following the documentation, make sure the
  25. resulting directories are owned by the \"buildbot\" user and point
  26. \"${ROOT}etc/conf.d/buildslave\" at the right location. The scripts can
  27. run as a different user if desired. If you need to run more than one
  28. build slave, just copy the scripts."
  29. }
  30. src_install() {
  31. distutils-r1_src_install
  32. doman docs/buildslave.1
  33. newconfd "${FILESDIR}/buildslave.confd" buildslave
  34. newinitd "${FILESDIR}/buildslave.initd" buildslave
  35. systemd_dounit "${FILESDIR}/buildslave.service"
  36. readme.gentoo_create_doc
  37. }
  38. pkg_postinst() {
  39. readme.gentoo_print_elog
  40. }