buildbot-waterfall-view-0.9.1.ebuild 1001 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PYTHON_REQ_USE="sqlite"
  5. PYTHON_COMPAT=( python2_7 )
  6. EGIT_REPO_URI="git://github.com/buildbot/buildbot.git"
  7. [[ ${PV} == *9999 ]] && inherit git-r3
  8. inherit distutils-r1
  9. DESCRIPTION="Buildbot waterfall-view plugin"
  10. HOMEPAGE="http://buildbot.net/ https://github.com/buildbot/buildbot https://pypi.python.org/pypi/buildbot-waterfall-view"
  11. MY_V="0.9.1"
  12. MY_P="${PN}-${MY_V}"
  13. [[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
  14. LICENSE="GPL-2"
  15. SLOT="0"
  16. if [[ ${PV} == *9999 ]]; then
  17. KEYWORDS=""
  18. else
  19. KEYWORDS="~amd64"
  20. fi
  21. RDEPEND="
  22. ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
  23. dev-python/mock[${PYTHON_USEDEP}]
  24. ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
  25. "
  26. DEPEND="${RDEPEND}
  27. >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
  28. "
  29. S="${WORKDIR}/${MY_P}"
  30. #[[ ${PV} == *9999 ]] && S=${S}/www/base
  31. python_install_all() {
  32. distutils-r1_python_install_all
  33. }