bustle-0.5.4.ebuild 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. # ebuild generated by hackport 0.4.5.9999
  5. CABAL_FEATURES="bin test-suite"
  6. inherit eutils haskell-cabal
  7. DESCRIPTION="Draw sequence diagrams of D-Bus traffic"
  8. HOMEPAGE="http://hackage.haskell.org/package/bustle"
  9. SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
  10. LICENSE="LGPL-2 GPL-2 GPL-3"
  11. SLOT="0"
  12. KEYWORDS="amd64 x86"
  13. IUSE="interactivetests +threaded"
  14. RDEPEND="dev-haskell/cairo:=
  15. >=dev-haskell/dbus-0.10:=
  16. dev-haskell/gio:=
  17. dev-haskell/glib:=
  18. >=dev-haskell/gtk3-0.13.7:0=
  19. >=dev-haskell/hgettext-0.1.5:=
  20. dev-haskell/mtl:=
  21. dev-haskell/pango:=
  22. dev-haskell/parsec:=
  23. dev-haskell/pcap:=
  24. dev-haskell/setlocale:=
  25. dev-haskell/text:=
  26. >=dev-lang/ghc-7.4.1:=
  27. dev-libs/glib:2
  28. dev-perl/Locale-gettext
  29. "
  30. DEPEND="${RDEPEND}
  31. >=dev-haskell/cabal-1.8
  32. virtual/pkgconfig
  33. test? ( dev-haskell/hunit
  34. dev-haskell/quickcheck
  35. dev-haskell/test-framework
  36. dev-haskell/test-framework-hunit )
  37. "
  38. src_configure() {
  39. haskell-cabal_src_configure \
  40. $(cabal_flag interactivetests interactivetests) \
  41. $(cabal_flag threaded threaded)
  42. }
  43. src_compile() {
  44. # compile haskell part
  45. cabal_src_compile || die "could not build haskell parts"
  46. # compile C part
  47. emake \
  48. "CC=$(tc-getCC)" \
  49. "CFLAGS=${CFLAGS}" \
  50. "CPPFLAGS=${CPPFLAGS}" \
  51. "LDFLAGS=${LDFLAGS}"
  52. }
  53. src_install() {
  54. # install haskell part
  55. cabal_src_install || die "could not install haskell parts"
  56. dobin "${S}"/dist/build/bustle-pcap
  57. doman bustle-pcap.1
  58. dodoc README.md HACKING.md NEWS.md
  59. }