confix-2.3.5-r2.ebuild 1.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. DISTUTILS_SINGLE_IMPL=1
  6. inherit distutils-r1
  7. DESCRIPTION="Confix: A Build Tool on Top of GNU Automake"
  8. HOMEPAGE="http://confix.sourceforge.net"
  9. SRC_URI="mirror://sourceforge/confix/Confix-${PV}.tar.bz2"
  10. LICENSE="GPL-2"
  11. SLOT="2"
  12. KEYWORDS="~amd64 ~x86 ~ppc-aix ~x64-cygwin ~x86-linux ~sparc-solaris ~x86-solaris"
  13. IUSE=""
  14. DEPEND=""
  15. RDEPEND="dev-util/confix-wrapper
  16. sys-devel/autoconf-archive
  17. sys-devel/automake
  18. sys-devel/libtool"
  19. S="${WORKDIR}/Confix-${PV}"
  20. PATCHES=( # find jni-include dirs on hpux.
  21. "${FILESDIR}"/2.1.0/jni-hpux.patch
  22. # add .exe extension to TESTS
  23. "${FILESDIR}"/2.3.0/exeext.patch
  24. # use external autoconf archive
  25. "${FILESDIR}"/2.3.0/ext-ac-archive.patch
  26. # link local libraries first.
  27. "${FILESDIR}"/2.3.0/local-libs-first.patch
  28. # don't use automake 1.9, but any newer too...
  29. "${FILESDIR}"/2.3.0/new-automake.patch )
  30. pkg_setup() {
  31. python-single-r1_pkg_setup
  32. }
  33. pkg_preinst() {
  34. local RV=2.3.0
  35. if has_version "<dev-util/confix-${RV}"; then
  36. einfo "After merging ${P} you might have to remerge all packages built"
  37. einfo "with <dev-util/confix-${RV} in your EPREFIX to get all the"
  38. einfo "repo files useable with current ${PN}".
  39. ewarn
  40. ewarn "Use this command (copy&paste) to identify packages built with confix"
  41. ewarn "needing a remerge in your particular instance of Gentoo Prefix:"
  42. ewarn
  43. # use 'echo' to get this command from here:
  44. ewarn "( cd \$(portageq envvar EPREFIX)/var/db/pkg || exit 1;" \
  45. "pattern=\$(cd ../../.. && echo \$(ls -d" \
  46. "usr/share/confix*/repo | grep -v confix-${RV}) |" \
  47. "sed -e 's, ,|,g'); if [[ -z \${pattern} ]]; then echo" \
  48. "'No more packages were built with broken Confix.'; exit 0;" \
  49. "fi; emerge --ask --oneshot \$(grep -lE \"(\${pattern})\"" \
  50. "*/*/CONTENTS | sed -e 's,^,>=,;s,/CONTENTS,,')" \
  51. ")"
  52. ewarn
  53. fi
  54. }