cwdiff-0.3.0.ebuild 889 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. if [ "${PV}" = "9999" ]; then
  5. EGIT_REPO_URI="git://github.com/junghans/${PN}.git https://github.com/junghans/${PN}.git"
  6. inherit git-r3
  7. KEYWORDS=""
  8. else
  9. SRC_URI="https://github.com/junghans/cwdiff/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  10. KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x64-macos ~x86-macos"
  11. fi
  12. DESCRIPTION="A script that wraps wdiff to support directories and colorize the output"
  13. HOMEPAGE="https://github.com/junghans/cwdiff"
  14. LICENSE="GPL-2"
  15. SLOT="0"
  16. IUSE="a2ps mercurial"
  17. DEPEND="sys-apps/help2man
  18. sys-apps/coreutils"
  19. RDEPEND="
  20. sys-apps/sed
  21. app-shells/bash
  22. app-text/wdiff
  23. sys-apps/diffutils
  24. a2ps? ( app-text/a2ps )
  25. mercurial? ( dev-vcs/mercurial )
  26. "
  27. src_install() {
  28. emake DESTDIR="${ED}" $(usex mercurial '' 'HGRCDIR=') install
  29. dodoc README.md
  30. }