cwdiff-0.4.0.ebuild 859 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. if [ "${PV}" = "9999" ]; then
  5. EGIT_REPO_URI="git://github.com/junghans/${PN}.git https://github.com/junghans/${PN}.git"
  6. inherit git-r3
  7. KEYWORDS=""
  8. else
  9. SRC_URI="https://github.com/junghans/cwdiff/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  10. KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x64-macos ~x86-macos"
  11. fi
  12. DESCRIPTION="A script that wraps wdiff to support directories and colorize the output"
  13. HOMEPAGE="https://github.com/junghans/cwdiff"
  14. LICENSE="GPL-2"
  15. SLOT="0"
  16. IUSE="mercurial"
  17. DEPEND="sys-apps/help2man
  18. sys-apps/coreutils"
  19. RDEPEND="
  20. sys-apps/sed
  21. app-shells/bash
  22. app-text/wdiff
  23. sys-apps/diffutils
  24. mercurial? ( dev-vcs/mercurial )
  25. "
  26. src_install() {
  27. emake DESTDIR="${ED}" $(usex mercurial '' 'HGRCDIR=') install
  28. dodoc README.md
  29. }