devhelp-3.22.0.ebuild 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. # gedit-3.8 is python3 only, this also per:
  5. # https://bugzilla.redhat.com/show_bug.cgi?id=979450
  6. PYTHON_COMPAT=( python{3_4,3_5} )
  7. inherit gnome2 python-single-r1 toolchain-funcs
  8. DESCRIPTION="An API documentation browser for GNOME"
  9. HOMEPAGE="https://wiki.gnome.org/Apps/Devhelp"
  10. LICENSE="GPL-2+"
  11. SLOT="0/3-1" # subslot = 3-(libdevhelp-3 soname version)
  12. KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-fbsd ~x86-fbsd"
  13. IUSE="gedit"
  14. REQUIRED_USE="gedit? ( ${PYTHON_REQUIRED_USE} )"
  15. COMMON_DEPEND="
  16. >=dev-libs/glib-2.37.3:2[dbus]
  17. >=x11-libs/gtk+-3.19.3:3
  18. >=net-libs/webkit-gtk-2.6.0:4
  19. "
  20. RDEPEND="${COMMON_DEPEND}
  21. gedit? (
  22. ${PYTHON_DEPS}
  23. app-editors/gedit[introspection,python,${PYTHON_USEDEP}]
  24. dev-python/pygobject:3[${PYTHON_USEDEP}]
  25. x11-libs/gtk+[introspection] )
  26. gnome-base/gsettings-desktop-schemas
  27. "
  28. DEPEND="${COMMON_DEPEND}
  29. ${PYTHON_DEPS}
  30. >=dev-util/intltool-0.40
  31. gnome-base/gnome-common
  32. virtual/pkgconfig
  33. "
  34. pkg_setup() {
  35. use gedit && python-single-r1_pkg_setup
  36. }
  37. src_prepare() {
  38. if ! use gedit ; then
  39. sed -e '/SUBDIRS/ s/gedit-plugin//' -i misc/Makefile.{am,in} || die
  40. fi
  41. gnome2_src_prepare
  42. }
  43. src_configure() {
  44. local myconf=""
  45. # ICC is crazy, silence warnings (bug #154010)
  46. if [[ $(tc-getCC) == "icc" ]] ; then
  47. myconf="--with-compile-warnings=no"
  48. fi
  49. gnome2_src_configure ${myconf}
  50. }