dwdiff-2.1.0-r1.ebuild 842 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="diff-like program that operates at the word level instead of the line level"
  6. HOMEPAGE="http://os.ghalkes.nl/dwdiff.html"
  7. SRC_URI="http://os.ghalkes.nl/dist/${P}.tar.bz2"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
  11. IUSE="nls"
  12. CDEPEND="dev-libs/icu:="
  13. RDEPEND="
  14. ${CDEPEND}
  15. sys-apps/diffutils"
  16. DEPEND="
  17. ${CDEPEND}
  18. nls? ( sys-devel/gettext )"
  19. src_prepare() {
  20. default
  21. sed -i \
  22. -e '/INSTALL/s:COPYING::' \
  23. Makefile.in || die
  24. }
  25. src_configure() {
  26. ./configure \
  27. --prefix=/usr \
  28. $(use_with nls gettext)
  29. }
  30. src_compile() {
  31. emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
  32. }
  33. src_install() {
  34. emake prefix="${D}/usr" docdir="${D}/usr/share/doc/${PF}" install
  35. }