eric-17.03.ebuild 1.7 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=( python2_7 python3_{4,5} )
  5. PYTHON_REQ_USE="sqlite,xml"
  6. inherit python-single-r1
  7. DESCRIPTION="A full featured Python IDE using PyQt and QScintilla"
  8. HOMEPAGE="http://eric-ide.python-projects.org/"
  9. LICENSE="GPL-3"
  10. SLOT="6"
  11. MY_P=${PN}${SLOT}-${PV}
  12. SRC_URI="mirror://sourceforge/eric-ide/${PN}${SLOT}/stable/${PV}/${MY_P}.tar.gz"
  13. KEYWORDS="~amd64 ~ppc64 ~x86"
  14. IUSE=""
  15. DEPEND="
  16. ${PYTHON_DEPS}
  17. >=dev-python/sip-4.14.3[${PYTHON_USEDEP}]
  18. >=dev-python/PyQt5-5.5.1[${PYTHON_USEDEP},gui,help,network,printsupport,sql,svg,webkit]
  19. >=dev-python/qscintilla-python-2.8[qt5,${PYTHON_USEDEP}]
  20. "
  21. RDEPEND="${DEPEND}
  22. >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
  23. >=dev-python/coverage-4.1.0[${PYTHON_USEDEP}]
  24. >=dev-python/pygments-2.1.3[${PYTHON_USEDEP}]
  25. !dev-util/eric:4
  26. !dev-util/eric:5
  27. "
  28. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  29. S=${WORKDIR}/${MY_P}
  30. DOCS=(changelog README.rst THANKS)
  31. src_prepare() {
  32. default
  33. # Delete internal copies of dev-python/chardet and dev-python/pygments
  34. rm -fr eric/ThirdParty/{CharDet,Pygments} || die
  35. # Delete internal copy of dev-python/coverage
  36. rm -fr eric/DebugClients/Python{,3}/coverage || die
  37. sed -i -e 's/from DebugClients\.Python3\?\.coverage/from coverage/' \
  38. $(grep -lr 'from DebugClients\.Python3\?\.coverage' .) || die
  39. # Fix desktop files (bug 458092)
  40. sed -i -re '/^Categories=/s:(Python|QtWeb):X-&:g' eric/eric6{,_{,web}browser}.desktop || die
  41. }
  42. src_install() {
  43. "${PYTHON}" install.py \
  44. -b "${EPREFIX}/usr/bin" \
  45. -d "$(python_get_sitedir)" \
  46. -i "${D}" \
  47. -c \
  48. -z \
  49. || die
  50. python_optimize
  51. einstalldocs
  52. }