gtk-doc-am-1.25-r1.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GNOME_ORG_MODULE="gtk-doc"
  5. inherit gnome.org
  6. DESCRIPTION="Automake files from gtk-doc"
  7. HOMEPAGE="http://www.gtk.org/gtk-doc/"
  8. LICENSE="GPL-2 FDL-1.1"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
  11. RDEPEND=">=dev-lang/perl-5.18"
  12. DEPEND="${RDEPEND}
  13. virtual/pkgconfig
  14. !<dev-util/gtk-doc-${GNOME_ORG_PVP}
  15. "
  16. # This ebuild doesn't even compile anything, causing tests to fail when updating (bug #316071)
  17. RESTRICT="test"
  18. src_configure() {
  19. # Duplicate autoconf checks so we don't have to call configure
  20. local PERL=$(type -P perl)
  21. test -n "${PERL}" || die "Perl not found!"
  22. "${PERL}" -e "require v5.18.0" || die "perl >= 5.18.0 is required for gtk-doc"
  23. # Replicate AC_SUBST
  24. sed -e "s:@PERL@:${PERL}:g" -e "s:@VERSION@:${PV}:g" \
  25. "${S}/gtkdoc-rebase.in" > "${S}/gtkdoc-rebase" || die "sed failed!"
  26. }
  27. src_compile() {
  28. :
  29. }
  30. src_install() {
  31. dobin gtkdoc-rebase
  32. insinto /usr/share/aclocal
  33. doins gtk-doc.m4
  34. }