gtk-update-icon-cache-3.22.2.ebuild 969 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit gnome2
  5. DESCRIPTION="GTK update icon cache"
  6. HOMEPAGE="http://www.gtk.org/ https://github.com/EvaSDK/gtk-update-icon-cache"
  7. SRC_URI="https://dev.gentoo.org/~eva/distfiles/${PN}/${P}.tar.xz"
  8. LICENSE="LGPL-2+"
  9. SLOT="0"
  10. IUSE=""
  11. KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
  12. # man page was previously installed by gtk+:3 ebuild
  13. RDEPEND="
  14. >=dev-libs/glib-2.49.4:2
  15. >=x11-libs/gdk-pixbuf-2.30:2
  16. !<x11-libs/gtk+-2.24.28-r1:2
  17. !<x11-libs/gtk+-3.22.2:3
  18. "
  19. DEPEND="${RDEPEND}
  20. >=sys-devel/gettext-0.19.7
  21. virtual/pkgconfig
  22. "
  23. src_configure() {
  24. # man pages are shipped in tarball
  25. gnome2_src_configure --disable-man
  26. }
  27. src_install() {
  28. gnome2_src_install
  29. doman docs/${PN}.1
  30. }