hxd-0.70.02-r1.ebuild 569 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="Binary to hexadecimal converter"
  6. HOMEPAGE="http://www-tet.ee.tu-berlin.de/solyga/linux/"
  7. SRC_URI="http://linux.xulin.de/c/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86 ~sparc ~mips ~ppc"
  11. IUSE=""
  12. src_prepare() {
  13. epatch \
  14. "${FILESDIR}"/${P}-prll-flags.patch \
  15. "${FILESDIR}"/${P}-llong-redef.patch
  16. tc-export CC
  17. }
  18. src_install() {
  19. dobin hxd unhxd
  20. doman hxd.1 unhxd.1
  21. dodoc README TODO
  22. }