igprof-5.9.11.ebuild 689 B

123456789101112131415161718192021222324252627
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit cmake-utils
  5. DESCRIPTION="Ignominous Profiler for analysing application memory and performance characteristics"
  6. HOMEPAGE="http://igprof.org"
  7. SRC_URI="https://github.com/ktf/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="debug"
  12. # pcre is automagic dependency, let's make it unoptional
  13. # libatomic_ops is listed as dependency, but isn't actually used by package
  14. DEPEND="dev-libs/libpcre
  15. sys-libs/libunwind"
  16. RDEPEND="${DEPEND}"
  17. src_prepare() {
  18. sed -e 's/-Werror//g' -i CMakeLists.txt
  19. cmake-utils_src_prepare
  20. }