imediff2-1.1.2-r3.ebuild 747 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PYTHON_COMPAT=( python2_7 )
  5. PYTHON_REQ_USE="ncurses"
  6. inherit python-single-r1 versionator
  7. MY_P=${PN}_$(replace_version_separator 3 -)
  8. DESCRIPTION="An interactive, user friendly 2-way merge tool in text mode"
  9. HOMEPAGE="http://elonen.iki.fi/code/imediff/"
  10. SRC_URI="mirror://debian/pool/main/i/${PN}/${MY_P}.orig.tar.gz"
  11. LICENSE="GPL-2"
  12. SLOT="0"
  13. KEYWORDS="~amd64 ~x86"
  14. IUSE=""
  15. DEPEND="${PYTHON_DEPS}"
  16. RDEPEND="${DEPEND}"
  17. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  18. S=${WORKDIR}/${PN}
  19. src_compile() {
  20. # Otherwise the docs get regenerated :)
  21. :
  22. }
  23. src_install() {
  24. python_doscript imediff2
  25. dodoc AUTHORS README
  26. doman imediff2.1
  27. }