include-what-you-use-3.5.ebuild 708 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils cmake-utils flag-o-matic
  5. DESCRIPTION="find unused include directives in C/C++ programs"
  6. HOMEPAGE="https://github.com/include-what-you-use/include-what-you-use"
  7. SRC_URI="http://include-what-you-use.com/downloads/include-what-you-use-3.5.src.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. RDEPEND="=sys-devel/llvm-3.5*
  12. =sys-devel/clang-3.5*"
  13. DEPEND="${RDEPEND}"
  14. S=${WORKDIR}/${PN}
  15. src_prepare() {
  16. epatch_user
  17. }
  18. src_configure() {
  19. append-ldflags -L$(llvm-config --libdir)
  20. local mycmakeargs=(
  21. -DLLVM_PATH=$(llvm-config --libdir)
  22. )
  23. cmake-utils_src_configure
  24. }