lttng-ust-2.6.5.ebuild 634 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools versionator
  5. MY_P="${P/_rc/-rc}"
  6. MY_SLOT="$(get_version_component_range 1-2)"
  7. DESCRIPTION="Linux Trace Toolkit - UST library"
  8. HOMEPAGE="http://lttng.org"
  9. SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
  10. LICENSE="GPL-2"
  11. SLOT="0/${MY_SLOT}"
  12. KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
  13. IUSE="examples"
  14. DEPEND="dev-libs/userspace-rcu"
  15. RDEPEND="${DEPEND}"
  16. S="${WORKDIR}"/${MY_P}
  17. src_prepare() {
  18. if ! use examples; then
  19. sed -i -e '/SUBDIRS/s:examples::' doc/Makefile.am || die
  20. fi
  21. eautoreconf
  22. }