makepp-1.18.ebuild 907 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2009 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils
  4. DESCRIPTION="GNU make replacement"
  5. HOMEPAGE="http://makepp.sourceforge.net/"
  6. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~x86 ~ppc ~sparc alpha"
  10. IUSE=""
  11. DEPEND=">=dev-lang/perl-5.6.0"
  12. src_unpack() {
  13. unpack ${A}
  14. cd "${S}"
  15. epatch "${FILESDIR}"/${P}-install.patch
  16. # There is a sandbox violation in this test.
  17. # In future versions, this ebuild should try to find
  18. # a better way of avoiding this, but the current version
  19. # appears to have garbage NUL characters all over the test files,
  20. # making them complicated to edit.
  21. # Robert Coie <rac@gentoo.org> 2002.02.18
  22. rm "${S}"/makepp_tests/include.test
  23. }
  24. src_compile() {
  25. make test || die
  26. }
  27. src_install() {
  28. perl install.pl /usr "${D}" /usr/bin /usr/share/makepp /usr/share/doc/makepp
  29. }