nemiver-0.9.6.ebuild 1.3 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GNOME2_LA_PUNT="yes"
  5. inherit eutils gnome2
  6. DESCRIPTION="A gtkmm front end to the GNU Debugger (gdb)"
  7. HOMEPAGE="https://wiki.gnome.org/Apps/Nemiver"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="debug memoryview"
  12. RDEPEND="
  13. >=dev-libs/glib-2.16:2[dbus]
  14. >=dev-cpp/glibmm-2.30:2
  15. >=dev-cpp/gtkmm-3:3.0
  16. >=dev-cpp/gtksourceviewmm-3:3.0
  17. >=gnome-base/gsettings-desktop-schemas-0.0.1
  18. >=gnome-base/libgtop-2.19
  19. x11-libs/vte:2.91
  20. >=dev-db/sqlite-3:3
  21. sys-devel/gdb
  22. dev-libs/boost
  23. memoryview? ( >=app-editors/ghex-2.90:2 )
  24. "
  25. # FIXME: dynamiclayout needs unreleased stable gdlmm:3
  26. # dynamiclayout? ( >=dev-cpp/gdlmm-3.0:3 )
  27. DEPEND="${RDEPEND}
  28. app-text/docbook-xml-dtd:4.1.2
  29. >=dev-util/intltool-0.40
  30. dev-util/itstool
  31. >=sys-devel/gettext-0.17
  32. virtual/pkgconfig
  33. "
  34. PATCHES=(
  35. # Use RefPtr::bool() operator in the conditions, fixed in next
  36. # version
  37. "${FILESDIR}/${P}-bool-build.patch"
  38. # Fix compiliation warnings & errors, fixed in next version
  39. "${FILESDIR}/${P}-fix-build.patch"
  40. )
  41. src_configure() {
  42. gnome2_src_configure \
  43. --disable-dynamiclayout \
  44. --disable-static \
  45. --disable-symsvis \
  46. --enable-gsettings \
  47. $(use_enable debug) \
  48. $(use_enable memoryview)
  49. }