obs-service-tar_scm-0.3.1.ebuild 660 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit obs-service
  5. HASH="1383144507.58d1af8"
  6. SRC_URI="${OBS_URI}/${P}.${HASH}.tar.gz"
  7. IUSE=""
  8. KEYWORDS="amd64 x86"
  9. DEPEND=""
  10. RDEPEND="${DEPEND}
  11. dev-vcs/bzr
  12. dev-vcs/git
  13. dev-vcs/mercurial
  14. dev-vcs/subversion
  15. "
  16. S="${WORKDIR}/${P}.${HASH}"
  17. src_unpack() {
  18. default
  19. }
  20. src_install() {
  21. # different folder and files in this module
  22. exeinto /usr/libexec/obs/service
  23. doexe ${OBS_SERVICE_NAME}
  24. insinto /usr/libexec/obs/service
  25. doins ${OBS_SERVICE_NAME}.service
  26. insinto /etc/obs/services
  27. newins ${OBS_SERVICE_NAME}.rc ${OBS_SERVICE_NAME}
  28. }