pkgconfig-0.29.1.ebuild 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. # Do not inherit autotools in non-live ebuild - causes circular dependency, bug #550856
  5. inherit eutils flag-o-matic libtool multilib multilib-minimal
  6. MY_P=pkg-config-${PV}
  7. if [[ ${PV} == *9999* ]]; then
  8. # 1.12 is only needed for tests due to some am__check_pre / LOG_DRIVER
  9. # weirdness with "/bin/bash /bin/sh" in arguments chain with >=1.13
  10. WANT_AUTOMAKE=1.12
  11. EGIT_REPO_URI="git://anongit.freedesktop.org/pkg-config"
  12. EGIT_CHECKOUT_DIR=${WORKDIR}/${MY_P}
  13. inherit autotools git-r3
  14. else
  15. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
  16. SRC_URI="https://pkgconfig.freedesktop.org/releases/${MY_P}.tar.gz"
  17. fi
  18. DESCRIPTION="Package config system that manages compile/link flags"
  19. HOMEPAGE="https://pkgconfig.freedesktop.org/wiki/"
  20. LICENSE="GPL-2"
  21. SLOT="0"
  22. IUSE="elibc_FreeBSD elibc_glibc hardened internal-glib"
  23. RDEPEND="!internal-glib? ( >=dev-libs/glib-2.34.3[${MULTILIB_USEDEP}] )
  24. !dev-util/pkgconf[pkg-config]
  25. !dev-util/pkg-config-lite
  26. !dev-util/pkgconfig-openbsd[pkg-config]
  27. virtual/libintl"
  28. DEPEND="${RDEPEND}"
  29. S=${WORKDIR}/${MY_P}
  30. DOCS=( AUTHORS NEWS README )
  31. src_prepare() {
  32. sed -i -e "s|^prefix=/usr\$|prefix=${EPREFIX}/usr|" check/simple.pc || die #434320
  33. eapply_user
  34. if [[ ${PV} == *9999* ]]; then
  35. eautoreconf
  36. else
  37. elibtoolize # Required for FreeMiNT wrt #333429
  38. fi
  39. if [[ ${CHOST} == *-solaris* ]] ; then
  40. # fix standards conflicts
  41. sed -i -e 's/\(_XOPEN_SOURCE\(_EXTENDED\)\?\|__EXTENSIONS__\)/ \1_DISABLED/' \
  42. glib/configure || die
  43. sed -i -e '/#define\s\+_POSIX_SOURCE/d' \
  44. glib/glib/giounix.c || die
  45. fi
  46. }
  47. multilib_src_configure() {
  48. local myconf
  49. if use internal-glib; then
  50. myconf+=' --with-internal-glib'
  51. # non-glibc platforms use GNU libiconv, but configure needs to
  52. # know about that not to get confused when it finds something
  53. # outside the prefix too
  54. if use prefix && use !elibc_glibc ; then
  55. myconf+=" --with-libiconv=gnu"
  56. # add the libdir for libtool, otherwise it'll make love with system
  57. # installed libiconv
  58. append-ldflags "-L${EPREFIX}/usr/$(get_libdir)"
  59. # the glib objects reference symbols from these frameworks,
  60. # not good, esp. since Carbon should be deprecated
  61. [[ ${CHOST} == *-darwin* ]] && \
  62. append-ldflags -framework CoreFoundation -framework Carbon
  63. if [[ ${CHOST} == *-solaris* ]] ; then
  64. # required due to __EXTENSIONS__
  65. append-cppflags -DENABLE_NLS
  66. # similar to Darwin
  67. append-ldflags -lintl
  68. fi
  69. fi
  70. else
  71. if ! has_version dev-util/pkgconfig; then
  72. export GLIB_CFLAGS="-I${EPREFIX}/usr/include/glib-2.0 -I${EPREFIX}/usr/$(get_libdir)/glib-2.0/include"
  73. export GLIB_LIBS="-lglib-2.0"
  74. fi
  75. fi
  76. use ppc64 && use hardened && replace-flags -O[2-3] -O1
  77. # Force using all the requirements when linking, so that needed -pthread
  78. # lines are inherited between libraries
  79. use elibc_FreeBSD && myconf+=' --enable-indirect-deps'
  80. [[ ${PV} == *9999* ]] && myconf+=' --enable-maintainer-mode'
  81. ECONF_SOURCE=${S} \
  82. econf \
  83. --docdir="${EPREFIX}"/usr/share/doc/${PF}/html \
  84. --with-system-include-path="${EPREFIX}"/usr/include \
  85. --with-system-library-path="${EPREFIX}"/usr/$(get_libdir) \
  86. ${myconf}
  87. }
  88. multilib_src_install() {
  89. emake DESTDIR="${D}" install
  90. if use prefix; then
  91. # Add an explicit reference to $EPREFIX to PKG_CONFIG_PATH to
  92. # simplify cross-prefix builds
  93. echo "PKG_CONFIG_PATH=${EPREFIX}/usr/$(get_libdir)/pkgconfig:${EPREFIX}/usr/share/pkgconfig" >> "${T}"/99${PN}
  94. doenvd "${T}"/99${PN}
  95. fi
  96. }