pycharm-professional-2017.1.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils readme.gentoo-r1
  5. DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
  6. HOMEPAGE="http://www.jetbrains.com/pycharm/"
  7. SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
  8. LICENSE="PyCharm_Academic PyCharm_Classroom PyCharm PyCharm_OpenSource PyCharm_Preview"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. RDEPEND=">=virtual/jre-1.8
  13. dev-python/pip"
  14. DEPEND=""
  15. RESTRICT="mirror strip"
  16. QA_PREBUILT="opt/${PN}/bin/fsnotifier
  17. opt/${PN}/bin/fsnotifier64
  18. opt/${PN}/bin/fsnotifier-arm
  19. opt/${PN}/bin/libyjpagent-linux.so
  20. opt/${PN}/bin/libyjpagent-linux64.so"
  21. MY_PN=${PN/-professional/}
  22. S="${WORKDIR}/${MY_PN}-${PV}"
  23. src_prepare() {
  24. default
  25. rm -rf jre || die
  26. }
  27. src_install() {
  28. insinto /opt/${PN}
  29. doins -r *
  30. fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
  31. dosym /opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
  32. newicon "bin/${MY_PN}.png" ${PN}.png
  33. make_desktop_entry ${PN} "${PN}" "${PN}"
  34. readme.gentoo_create_doc
  35. }