regexxer-0.10.ebuild 724 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. GCONF_DEBUG=no
  5. inherit autotools eutils flag-o-matic gnome2
  6. DESCRIPTION="An interactive tool for performing search and replace operations"
  7. HOMEPAGE="http://regexxer.sourceforge.net/"
  8. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 ~ppc x86"
  12. RDEPEND=">=dev-cpp/glibmm-2.28
  13. dev-cpp/gtkmm:3.0
  14. dev-cpp/gtksourceviewmm:3.0"
  15. DEPEND="${RDEPEND}
  16. dev-util/intltool
  17. virtual/pkgconfig
  18. sys-devel/gettext"
  19. src_prepare() {
  20. append-cxxflags -std=c++11
  21. epatch "${FILESDIR}"/${P}-glib-2.32.patch
  22. epatch "${FILESDIR}"/${P}-sandbox.patch
  23. eautoreconf
  24. gnome2_src_prepare
  25. }