scanmem-0.15.3.ebuild 953 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python{2_7,3_4,3_5} )
  5. inherit autotools eutils python-single-r1
  6. DESCRIPTION="Locate and modify variables in executing processes"
  7. HOMEPAGE="https://github.com/scanmem/scanmem"
  8. SRC_URI="https://github.com/scanmem/scanmem/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="gui"
  13. DEPEND="sys-libs/readline:="
  14. RDEPEND="${DEPEND}
  15. gui? (
  16. ${PYTHON_DEPS}
  17. dev-python/pygobject:3
  18. sys-auth/polkit
  19. )"
  20. REQUIRED_USE="gui? ( ${PYTHON_REQUIRED_USE} )"
  21. pkg_setup() {
  22. use gui && python-single-r1_pkg_setup
  23. }
  24. src_prepare() {
  25. sed -i "/CFLAGS/d" Makefile.am || die
  26. eautoreconf
  27. }
  28. src_configure() {
  29. econf \
  30. --docdir="/usr/share/doc/${PF}" \
  31. $(use_enable gui)
  32. }
  33. src_install() {
  34. default
  35. if use gui ; then
  36. docinto gui
  37. dodoc gui/{README,TODO}
  38. python_fix_shebang "${D}"
  39. fi
  40. }