serialtalk-1.2.ebuild 537 B

12345678910111213141516171819202122232425
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils
  5. if [[ ${PV} == 9999 ]]; then
  6. inherit git-r3
  7. EGIT_REPO_URI="https://github.com/BGO-OD/serialtalk.git"
  8. else
  9. SRC_URI="https://github.com/BGO-OD/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  10. KEYWORDS="~amd64 ~x86"
  11. fi
  12. DESCRIPTION="simple command-line tool to talk to serial devices"
  13. HOMEPAGE="https://github.com/BGO-OD/serialtalk"
  14. LICENSE="GPL-3+"
  15. SLOT="0"
  16. src_install() {
  17. cmake-utils_src_install
  18. }