shards-0.7.1.ebuild 518 B

12345678910111213141516171819202122232425
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="Dependency manager for the Crystal language"
  5. HOMEPAGE="https://github.com/crystal-lang/shards"
  6. SRC_URI="https://github.com/crystal-lang/shards/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  7. LICENSE="Apache-2.0"
  8. SLOT="0"
  9. KEYWORDS="~amd64"
  10. DEPEND="
  11. >dev-lang/crystal-0.11.1[yaml]
  12. "
  13. RDEPEND="${DEPEND}"
  14. RESTRICT=test # missing files in tarball
  15. src_install() {
  16. dobin bin/${PN}
  17. dodoc README.md
  18. }