123456789101112131415161718192021222324252627282930313233343536373839404142434445464748 |
- # Copyright 1999-2014 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=5
- #if LIVE
- AUTOTOOLS_AUTORECONF=yes
- EGIT_REPO_URI="https://bitbucket.org/mgorny/${PN}.git"
- inherit git-r3
- #endif
- inherit autotools-utils
- DESCRIPTION="Efficient (partially uncompressed) SquashFS binary delta tool"
- HOMEPAGE="https://bitbucket.org/mgorny/squashdelta/"
- SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
- # uses public-domain murmurhash3
- LICENSE="BSD public-domain"
- SLOT="0"
- KEYWORDS="~amd64 ~x86"
- IUSE="lz4 +lzo"
- #if LIVE
- KEYWORDS=
- SRC_URI=
- #endif
- COMMON_DEPEND="
- lz4? ( app-arch/lz4:0= )
- lzo? ( dev-libs/lzo:2= )"
- RDEPEND="${COMMON_DEPEND}
- dev-util/xdelta:3"
- DEPEND=${COMMON_DEPEND}
- # SquashDelta does not make much sense without a compression algo.
- REQUIRED_USE="|| ( lz4 lzo )"
- src_configure() {
- local myeconfargs=(
- $(use_enable lz4)
- $(use_enable lzo)
- )
- autotools-utils_src_configure
- }
|