stressapptest-1.0.8.ebuild 610 B

12345678910111213141516171819202122232425
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit flag-o-matic
  5. DESCRIPTION="Stressful Application Test"
  6. HOMEPAGE="https://github.com/stressapptest/stressapptest"
  7. SRC_URI="https://github.com/stressapptest/stressapptest/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="Apache-2.0"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~mips ~x86"
  11. IUSE="debug"
  12. RDEPEND="dev-libs/libaio"
  13. DEPEND="${RDEPEND}"
  14. src_configure() {
  15. # Matches the configure & sat.cc logic.
  16. use debug || append-cppflags -DNDEBUG -DCHECKOPTS
  17. econf --disable-default-optimizations
  18. }