umockdev-0.8.11.ebuild 680 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python{2_7,3_4} )
  5. inherit python-any-r1 autotools-utils
  6. DESCRIPTION="Mock hardware devices for creating unit tests"
  7. HOMEPAGE="https://github.com/martinpitt/umockdev/"
  8. SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.xz"
  9. LICENSE="LGPL-2.1+"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="static-libs test"
  13. RDEPEND="virtual/libgudev:=
  14. virtual/libudev:=
  15. >=dev-libs/glib-2.32:2"
  16. DEPEND="${RDEPEND}
  17. test? ( ${PYTHON_DEPS} )
  18. app-arch/xz-utils
  19. virtual/pkgconfig"
  20. RESTRICT="test"
  21. PATCHES=(
  22. "${FILESDIR}"/${P}-sysmacros.patch #579988
  23. )