darcs-2.10.3-r1.ebuild 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. # ebuild generated by hackport 0.4.6.9999
  5. #hackport: flags: +library,+executable,-hpc,-warn-as-error,+pkgconfig,-rts,-static,-optimize,hashed-storage-diff:diff
  6. CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
  7. inherit haskell-cabal
  8. DESCRIPTION="a distributed, interactive, smart revision control system"
  9. HOMEPAGE="http://darcs.net/"
  10. SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
  11. LICENSE="GPL-2"
  12. SLOT="0/${PV}"
  13. KEYWORDS="~amd64 ~x86"
  14. IUSE="+curl diff +http +network-uri +terminfo +threaded"
  15. RESTRICT=test # occasionally hangs on directory creation race conditions
  16. RDEPEND=">=dev-haskell/attoparsec-0.11:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
  17. >=dev-haskell/base16-bytestring-0.1:=[profile?] <dev-haskell/base16-bytestring-0.2:=[profile?]
  18. >=dev-haskell/binary-0.5:=[profile?] <dev-haskell/binary-0.9:=[profile?]
  19. >=dev-haskell/cryptohash-0.4:=[profile?] <dev-haskell/cryptohash-0.12:=[profile?]
  20. >=dev-haskell/data-ordlist-0.4:=[profile?] <dev-haskell/data-ordlist-0.5:=[profile?]
  21. >=dev-haskell/hashable-1.0:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
  22. >=dev-haskell/haskeline-0.6.3:=[profile?] <dev-haskell/haskeline-0.8:=[profile?]
  23. >=dev-haskell/html-1.0:=[profile?] <dev-haskell/html-1.1:=[profile?]
  24. >=dev-haskell/mmap-0.5:=[profile?] <dev-haskell/mmap-0.6:=[profile?]
  25. >=dev-haskell/mtl-2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
  26. >=dev-haskell/old-locale-1.0:=[profile?] <dev-haskell/old-locale-1.1:=[profile?]
  27. >=dev-haskell/old-time-1.1:=[profile?] <dev-haskell/old-time-1.2:=[profile?]
  28. >=dev-haskell/parsec-3.1:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
  29. >=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-1.2:=[profile?]
  30. >=dev-haskell/regex-applicative-0.2:=[profile?] <dev-haskell/regex-applicative-0.4:=[profile?]
  31. >=dev-haskell/regex-compat-tdfa-0.95.1:=[profile?] <dev-haskell/regex-compat-tdfa-0.96:=[profile?]
  32. >=dev-haskell/sandi-0.2:=[profile?] <dev-haskell/sandi-0.4:=[profile?]
  33. >=dev-haskell/tar-0.4:=[profile?] <dev-haskell/tar-0.6:=[profile?]
  34. >=dev-haskell/text-0.11.3.1:=[profile?] <dev-haskell/text-1.3:=[profile?]
  35. >=dev-haskell/transformers-compat-0.4:=[profile?] <dev-haskell/transformers-compat-0.6:=[profile?]
  36. >=dev-haskell/unix-compat-0.1.2:=[profile?] <dev-haskell/unix-compat-0.5:=[profile?]
  37. >=dev-haskell/utf8-string-0.3.6:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
  38. >=dev-haskell/vector-0.7:=[profile?] <dev-haskell/vector-0.12:=[profile?]
  39. >=dev-haskell/zip-archive-0.2.3:=[profile?]
  40. >=dev-haskell/zlib-0.5.3.0:=[profile?] <dev-haskell/zlib-0.7.0.0:=[profile?]
  41. >=dev-lang/ghc-7.4.1:=
  42. virtual/libiconv
  43. >=dev-haskell/transformers-0.3:=[profile?] <dev-haskell/transformers-0.6:=[profile?]
  44. curl? ( net-misc/curl )
  45. diff? ( dev-haskell/lcs:=[profile?] )
  46. http? ( >=dev-haskell/http-4000.2.3:=[profile?] <dev-haskell/http-4000.4:=[profile?]
  47. network-uri? ( >=dev-haskell/network-2.6:=[profile?] <dev-haskell/network-2.7:=[profile?]
  48. >=dev-haskell/network-uri-2.6:=[profile?] <dev-haskell/network-uri-2.7:=[profile?] )
  49. !network-uri? ( >=dev-haskell/network-2.3:=[profile?] <dev-haskell/network-2.6:=[profile?] ) )
  50. terminfo? ( >=dev-haskell/terminfo-0.3:=[profile?] <dev-haskell/terminfo-0.5:=[profile?] )
  51. "
  52. DEPEND="${RDEPEND}
  53. >=dev-haskell/cabal-1.10
  54. test? ( >=dev-haskell/cmdargs-0.10 <dev-haskell/cmdargs-0.11
  55. >=dev-haskell/findbin-0.0 <dev-haskell/findbin-0.1
  56. >=dev-haskell/hunit-1.0 <dev-haskell/hunit-1.4
  57. >=dev-haskell/quickcheck-2.3 <dev-haskell/quickcheck-2.9
  58. >=dev-haskell/shelly-1.6.2 <dev-haskell/shelly-1.7
  59. >=dev-haskell/split-0.1.4.1 <dev-haskell/split-0.3
  60. >=dev-haskell/test-framework-0.4.0 <dev-haskell/test-framework-0.9
  61. >=dev-haskell/test-framework-hunit-0.2.2 <dev-haskell/test-framework-hunit-0.4
  62. >=dev-haskell/test-framework-quickcheck2-0.3 <dev-haskell/test-framework-quickcheck2-0.4 )
  63. curl? ( virtual/pkgconfig )
  64. "
  65. src_prepare() {
  66. cabal_chdeps \
  67. 'base >= 4.5 && < 4.9' 'base >= 4.5' \
  68. 'zip-archive >= 0.2.3 && < 0.3' 'zip-archive >= 0.2.3'
  69. }
  70. src_configure() {
  71. haskell-cabal_src_configure \
  72. $(cabal_flag curl curl) \
  73. --flag=executable \
  74. $(cabal_flag diff hashed-storage-diff) \
  75. --flag=-hpc \
  76. $(cabal_flag http http) \
  77. --flag=library \
  78. $(cabal_flag network-uri network-uri) \
  79. --flag=-optimize \
  80. --flag=pkgconfig \
  81. --flag=-rts \
  82. --flag=-static \
  83. $(cabal_flag terminfo terminfo) \
  84. $(cabal_flag threaded threaded) \
  85. --flag=-warn-as-error
  86. }
  87. src_install() {
  88. haskell-cabal_src_install
  89. # fixup perms in such an an awkward way
  90. mv "${ED}/usr/share/man/man1/darcs.1" "${S}/darcs.1" || die "darcs.1 not found"
  91. doman "${S}/darcs.1" || die "failed to register darcs.1 as a manpage"
  92. }