violetland-0.4.3.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils multilib toolchain-funcs flag-o-matic cmake-utils games
  5. DESCRIPTION="Help a girl by name of Violet to struggle with hordes of monsters"
  6. HOMEPAGE="https://code.google.com/p/violetland/"
  7. SRC_URI="https://github.com/ooxi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-3 CC-BY-SA-3.0"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. RDEPEND="media-libs/libsdl[sound,video]
  13. media-libs/sdl-image[png]
  14. media-libs/sdl-mixer[vorbis]
  15. media-libs/sdl-ttf
  16. dev-libs/boost[threads(+)]
  17. virtual/opengl
  18. virtual/glu"
  19. DEPEND="${RDEPEND}"
  20. src_prepare() {
  21. sed -i \
  22. -e "/README_EN.TXT/d" \
  23. -e "/README_RU.TXT/d" \
  24. CMakeLists.txt || die "sed failed"
  25. epatch "${FILESDIR}"/${P}-boost150.patch
  26. }
  27. src_configure() {
  28. mycmakeargs=(
  29. "-DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
  30. "-DDATA_INSTALL_DIR=${GAMES_DATADIR}/${PN}"
  31. )
  32. cmake-utils_src_configure
  33. }
  34. src_compile() {
  35. cmake-utils_src_compile
  36. }
  37. src_install() {
  38. DOCS="README_EN.TXT CHANGELOG" cmake-utils_src_install
  39. newicon icon-light.png ${PN}.png
  40. make_desktop_entry ${PN} VioletLand
  41. prepgamesdirs
  42. }