afternoonstalker-1.1.5.ebuild 846 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools games
  5. DESCRIPTION="Clone of the 1981 Night Stalker video game by Mattel Electronics"
  6. HOMEPAGE="http://perso.b2b2c.ca/sarrazip/dev/afternoonstalker.html"
  7. SRC_URI="http://perso.b2b2c.ca/sarrazip/dev/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86 ~x86-fbsd"
  11. IUSE=""
  12. RDEPEND=">=dev-games/flatzebra-0.1.6"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig"
  15. src_prepare() {
  16. sed -i \
  17. -e "/^pkgsounddir/ s:sounds.*:\$(PACKAGE)/sounds:" \
  18. -e "/^desktopentrydir/ s:=.*:=/usr/share/applications:" \
  19. -e "/^pixmapdir/ s:=.*:=/usr/share/pixmaps:" \
  20. src/Makefile.am || die
  21. eautoreconf
  22. }
  23. src_install() {
  24. emake -C src DESTDIR="${D}" install
  25. doman doc/${PN}.6
  26. dodoc AUTHORS NEWS README THANKS
  27. prepgamesdirs
  28. }