amphetamine-0.8.10.ebuild 975 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils games
  5. DESCRIPTION="a cool Jump'n Run game offering some unique visual effects"
  6. HOMEPAGE="http://homepage.hispeed.ch/loehrer/amph/amph.html"
  7. SRC_URI="http://homepage.hispeed.ch/loehrer/amph/files/${P}.tar.bz2
  8. http://homepage.hispeed.ch/loehrer/amph/files/${PN}-data-0.8.6.tar.bz2"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 ppc x86 ~x86-fbsd"
  12. IUSE=""
  13. DEPEND="media-libs/libsdl[sound,video]
  14. x11-libs/libXpm"
  15. RDEPEND=${DEPEND}
  16. src_prepare() {
  17. epatch \
  18. "${FILESDIR}"/${P}-build.patch \
  19. "${FILESDIR}"/${P}-64bit.patch
  20. sed -i -e '55d' src/ObjInfo.cpp || die
  21. }
  22. src_compile() {
  23. emake INSTALL_DIR="${GAMES_DATADIR}"/${PN}
  24. }
  25. src_install() {
  26. newgamesbin amph ${PN}
  27. insinto "${GAMES_DATADIR}"/${PN}
  28. doins -r ../amph/*
  29. newicon amph.xpm ${PN}.xpm
  30. make_desktop_entry ${PN} Amphetamine ${PN}
  31. dodoc BUGS ChangeLog NEWS README
  32. prepgamesdirs
  33. }