aop-0.6.ebuild 705 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils games
  5. DESCRIPTION="Ambassador of Pain is a curses based game with only 64 lines of code"
  6. HOMEPAGE="http://raffi.at/view/code/aop"
  7. SRC_URI="http://www.raffi.at/code/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc ppc64 ~sparc x86 ~x86-fbsd"
  11. IUSE=""
  12. RDEPEND="sys-libs/ncurses:0"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig"
  15. src_prepare() {
  16. sed -i \
  17. -e "s#/usr/local/share#${GAMES_DATADIR}#" \
  18. aop.c || die
  19. epatch "${FILESDIR}"/${P}-as-needed.patch
  20. }
  21. src_install() {
  22. dogamesbin aop
  23. insinto "${GAMES_DATADIR}/${PN}"
  24. doins aop-level-*.txt
  25. prepgamesdirs
  26. }