ascii-invaders-0.1b.ebuild 685 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit games
  5. DESCRIPTION="Space invaders clone, using ncurses library"
  6. HOMEPAGE="https://packages.gentoo.org/package/games-arcade/ascii-invaders"
  7. SRC_URI="mirror://gentoo/invaders${PV}.tgz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~ppc-macos"
  11. IUSE=""
  12. RDEPEND="sys-libs/ncurses:0"
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig"
  15. S=${WORKDIR}/invaders
  16. src_prepare() {
  17. rm -f Makefile
  18. }
  19. src_compile() {
  20. emake LDLIBS="$(pkg-config ncurses --libs)" invaders
  21. }
  22. src_install() {
  23. newgamesbin invaders ${PN}
  24. dodoc TODO
  25. prepgamesdirs
  26. }