asteroid-1.1.ebuild 666 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils games
  5. DESCRIPTION="A modern version of the arcade classic that uses OpenGL"
  6. HOMEPAGE="http://chaoslizard.sourceforge.net/asteroid/"
  7. SRC_URI="mirror://sourceforge/chaoslizard/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86 ~x86-fbsd"
  11. IUSE=""
  12. DEPEND="virtual/opengl
  13. media-libs/freeglut
  14. virtual/glu
  15. media-libs/libsdl
  16. media-libs/sdl-mixer"
  17. RDEPEND=${DEPEND}
  18. src_prepare() {
  19. epatch "${FILESDIR}"/${P}-include.patch
  20. }
  21. src_install() {
  22. DOCS="$(echo asteroid-{authors,changes,readme}.txt)" \
  23. default
  24. prepgamesdirs
  25. }