sable-1.0.ebuild 836 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils games
  5. DESCRIPTION="A frantic 3D space shooter"
  6. HOMEPAGE="http://jeuxlibres.net/showgame/sable.html"
  7. SRC_URI="mirror://gentoo/${P}-src.tgz
  8. mirror://gentoo/${PN}.png"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. IUSE=""
  13. DEPEND="virtual/opengl
  14. media-libs/libsdl[joystick,opengl,sound,video]
  15. media-libs/sdl-image[png]
  16. media-libs/sdl-mixer"
  17. RDEPEND=${DEPEND}
  18. S=${WORKDIR}/${PN}
  19. src_prepare() {
  20. epatch "${FILESDIR}"/${P}-gentoo.patch
  21. }
  22. src_compile() {
  23. emake INSTALL_RESDIR="${GAMES_DATADIR}"
  24. }
  25. src_install() {
  26. dogamesbin ${PN}
  27. insinto "${GAMES_DATADIR}"/${PN}
  28. doins -r models sfx textures
  29. dodoc ChangeLog README
  30. doicon "${DISTDIR}"/${PN}.png
  31. make_desktop_entry ${PN} Sable
  32. prepgamesdirs
  33. }