biloba-0.9.3-r1.ebuild 999 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools eutils gnome2-utils
  5. DESCRIPTION="a board game, up to 4 players, with AI and network"
  6. HOMEPAGE="http://biloba.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/biloba/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. DEPEND="media-libs/libsdl:0[X,video,sound]
  13. media-libs/sdl-image[png]
  14. media-libs/sdl-mixer"
  15. RDEPEND=${DEPEND}
  16. PATCHES=(
  17. # X11 headers are checked but not used, everything is done through SDL
  18. "${FILESDIR}"/${P}-not-windows.patch
  19. "${FILESDIR}"/${P}-no-X11-dep.patch
  20. )
  21. src_prepare() {
  22. default
  23. # "missing" file is old, and warns about --run not being supported
  24. rm -f missing
  25. eautoreconf
  26. }
  27. src_install() {
  28. default
  29. newicon -s 64 biloba_icon.png ${PN}.png
  30. make_desktop_entry biloba Biloba
  31. }
  32. pkg_preinst() {
  33. gnome2_icon_savelist
  34. }
  35. pkg_postinst() {
  36. gnome2_icon_cache_update
  37. }
  38. pkg_postrm() {
  39. gnome2_icon_cache_update
  40. }