ccgo-0.3.6.5-r1.ebuild 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools eutils toolchain-funcs flag-o-matic
  5. DESCRIPTION="An IGS client written in C++"
  6. HOMEPAGE="http://ccdw.org/~cjj/prog/ccgo/"
  7. SRC_URI="http://ccdw.org/~cjj/prog/ccgo/src/${P}.tar.gz"
  8. LICENSE="GPL-3+"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~x86"
  11. IUSE="nls"
  12. RDEPEND="
  13. >=dev-cpp/gconfmm-2.6
  14. >=dev-cpp/gtkmm-2.4:2.4
  15. nls? ( virtual/libintl )"
  16. DEPEND="${RDEPEND}
  17. virtual/pkgconfig
  18. nls? ( sys-devel/gettext )"
  19. PATCHES=(
  20. "${FILESDIR}"/${P}-gcc4.patch
  21. )
  22. src_prepare() {
  23. default
  24. sed -i \
  25. -e '/^Encoding/d' \
  26. -e '/^Categories/ { s/Application;//; s/$/GTK;/ }' \
  27. ccgo.desktop.in || die
  28. sed -i \
  29. -e '/^localedir/s/=.*/=@localedir@/' \
  30. -e '/^appicondir/s:=.*:=/usr/share/pixmaps:' \
  31. -e '/^desktopdir/s:=.*:=/usr/share/applications:' \
  32. Makefile.am || die
  33. # cargo cult from bug #569528
  34. append-cxxflags -std=c++11 -fpermissive
  35. find . -name '*.hh' -exec sed -i -e '/sigc++\/object.h/d' {} + || die
  36. find . -name '*.cc' -exec sed -i -e 's/(bind(/(sigc::bind(/' {} + || die
  37. eautoreconf
  38. }
  39. src_configure() {
  40. econf \
  41. --localedir=/usr/share/locale \
  42. $(use_enable nls)
  43. }
  44. src_compile() {
  45. emake AR="$(tc-getAR)"
  46. }