domination-1.1.1.6-r1.ebuild 981 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils java-pkg-2 java-ant-2
  5. DESCRIPTION="The well-known board game, written in java"
  6. HOMEPAGE="http://domination.sourceforge.net"
  7. SRC_URI="mirror://sourceforge/domination/Domination_${PV}.zip"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86 ~x86-fbsd"
  11. IUSE=""
  12. RDEPEND=">=virtual/jre-1.5"
  13. DEPEND=">=virtual/jdk-1.5
  14. app-arch/unzip"
  15. S=${WORKDIR}/Domination
  16. EANT_BUILD_TARGET="game"
  17. pkg_setup() {
  18. java-pkg-2_pkg_setup
  19. }
  20. src_compile() {
  21. java-pkg-2_src_compile
  22. }
  23. src_install() {
  24. newbin "${S}"/FlashGUI.sh ${PN}
  25. sed -i \
  26. -e "s|cd.*|cd \"/usr/share\"/${PN}|" \
  27. "${D}/usr/bin"/${PN} \
  28. || die
  29. chmod +x "${D}/usr/bin"/${PN} || die
  30. insinto "/usr/share/${PN}"
  31. doins -r "${S}"/*
  32. rm -f "${D}/usr/share"/${PN}/*.cmd || die
  33. java-pkg_regjar "${D}//usr/share/${PN}"/*.jar
  34. newicon resources/icon.png ${PN}.png
  35. make_desktop_entry ${PN} "Domination"
  36. }