fruit-2.1.ebuild 958 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils versionator games
  5. MY_PV=$(replace_all_version_separators '')
  6. MY_P=${PN}_${MY_PV}_linux
  7. DESCRIPTION="UCI-only chess engine"
  8. HOMEPAGE="http://arctrix.com/nas/fruit/"
  9. SRC_URI="http://arctrix.com/nas/${PN}/${MY_P}.zip"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="amd64 x86"
  13. IUSE=""
  14. RDEPEND=""
  15. DEPEND="app-arch/unzip"
  16. S=${WORKDIR}/${MY_P}/src
  17. src_prepare() {
  18. epatch "${FILESDIR}/${P}"-gentoo.patch
  19. sed -i \
  20. -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
  21. option.cpp || die
  22. sed -i \
  23. -e '/^CXX/d' \
  24. -e '/^LDFLAGS/d' \
  25. Makefile || die
  26. }
  27. src_install() {
  28. dogamesbin ${PN}
  29. insinto "${GAMES_DATADIR}/${PN}"
  30. doins ../book_small.bin
  31. dodoc ../readme.txt ../technical_10.txt
  32. prepgamesdirs
  33. }
  34. pkg_postinst() {
  35. games_pkg_postinst
  36. elog "To use this engine you need to install a UCI chess GUI"
  37. elog "e.g. games-board/glchess"
  38. }