grhino-0.16.1-r1.ebuild 961 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils
  5. DESCRIPTION="Reversi game for GNOME, supporting the Go/Game Text Protocol"
  6. HOMEPAGE="http://rhino.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/rhino/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="gnome gtp nls"
  12. RDEPEND="gnome? ( =gnome-base/libgnomeui-2* )
  13. nls? ( virtual/libintl )"
  14. DEPEND="${RDEPEND}
  15. nls? ( sys-devel/gettext )"
  16. src_prepare() {
  17. default
  18. sed -i '/^(\|locale\|help\|omf\|icon\|)/s:@datadir@:/usr/share:' \
  19. Makefile.in || die
  20. }
  21. src_configure() {
  22. if use gnome || use gtp; then
  23. econf \
  24. --localedir=/usr/share/locale \
  25. $(use_enable gnome) \
  26. $(use_enable gtp) \
  27. $(use_enable nls)
  28. else
  29. econf \
  30. --localedir=/usr/share/locale \
  31. --enable-gtp \
  32. --disable-gnome \
  33. $(use_enable nls)
  34. fi
  35. }
  36. src_install() {
  37. default
  38. use gnome && make_desktop_entry ${PN} GRhino
  39. }