grhino-0.16.1.ebuild 980 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils games
  5. DESCRIPTION="Reversi game for GNOME, supporting the Go/Game Text Protocol"
  6. HOMEPAGE="http://rhino.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/rhino/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="gnome gtp nls"
  12. RDEPEND="gnome? ( =gnome-base/libgnomeui-2* )
  13. nls? ( virtual/libintl )"
  14. DEPEND="${RDEPEND}
  15. nls? ( sys-devel/gettext )"
  16. src_prepare() {
  17. sed -i '/^(\|locale\|help\|omf\|icon\|)/s:@datadir@:/usr/share:' \
  18. Makefile.in || die
  19. }
  20. src_configure() {
  21. if use gnome || use gtp; then
  22. egamesconf \
  23. --localedir=/usr/share/locale \
  24. $(use_enable gnome) \
  25. $(use_enable gtp) \
  26. $(use_enable nls)
  27. else
  28. egamesconf \
  29. --localedir=/usr/share/locale \
  30. --enable-gtp \
  31. --disable-gnome \
  32. $(use_enable nls)
  33. fi
  34. }
  35. src_install() {
  36. default
  37. use gnome && make_desktop_entry ${PN} GRhino
  38. prepgamesdirs
  39. }