lletters-0.1.95-r3.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils
  5. PATCH_LEVEL=3
  6. DESCRIPTION="Game that helps young kids learn their letters and numbers"
  7. HOMEPAGE="http://lln.sourceforge.net"
  8. SRC_URI="mirror://debian/pool/main/l/${PN}/${PN}_${PV}+gtk2.orig.tar.gz
  9. mirror://debian/pool/main/l/${PN}/${PN}_${PV}+gtk2-${PATCH_LEVEL}.diff.gz
  10. mirror://sourceforge/lln/${PN}-media-0.1.9a.tar.gz"
  11. LICENSE="GPL-2"
  12. SLOT="0"
  13. KEYWORDS="~amd64 ~ppc ~x86"
  14. IUSE="nls"
  15. RDEPEND="x11-libs/gtk+:2
  16. nls? ( virtual/libintl )"
  17. DEPEND="${RDEPEND}
  18. virtual/pkgconfig
  19. nls? ( sys-devel/gettext )"
  20. PATCHES=(
  21. "${WORKDIR}"/${PN}_${PV}+gtk2-${PATCH_LEVEL}.diff
  22. "${FILESDIR}"/${P}-build-2.patch
  23. "${FILESDIR}"/${P}-underlink.patch
  24. "${FILESDIR}"/${P}-make-382.patch
  25. )
  26. src_prepare() {
  27. default
  28. cp -r "${WORKDIR}"/{images,sounds} . || die
  29. }
  30. src_configure() {
  31. econf $(use_enable nls)
  32. }
  33. src_install () {
  34. default
  35. newdoc debian/changelog ChangeLog.debian
  36. doicon debian/${PN}.xpm
  37. make_desktop_entry ${PN} "Linux Letters and Numbers" ${PN}
  38. }