opengfx-0.5.4-r1.ebuild 846 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils
  5. DESCRIPTION="OpenGFX data files for OpenTTD"
  6. HOMEPAGE="http://bundles.openttdcoop.org/opengfx/"
  7. SRC_URI="http://bundles.openttdcoop.org/opengfx/releases/${PV}/${P}-source.tar.xz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~ppc ~x86"
  11. IUSE=""
  12. RESTRICT="test" # nml version affects the checksums that the test uses (bug #451444)
  13. DEPEND=">=games-util/nml-0.4.0
  14. games-util/grfcodec"
  15. RDEPEND=""
  16. S=${WORKDIR}/${P}-source
  17. PATCHES=(
  18. "${FILESDIR}/${P}-Makefile.patch"
  19. )
  20. src_compile() {
  21. emake GIMP="" help # print out the env to make bug reports better
  22. emake GIMP="" _V="" bundle_tar
  23. }
  24. src_install() {
  25. insinto "/usr/share/games/openttd/data/"
  26. doins *.grf opengfx.obg
  27. dodoc docs/{changelog.txt,readme.txt}
  28. }