sound-of-sorting-0.6.6_pre20151107-r1.ebuild 734 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. WX_GTK_VER="3.0"
  5. inherit vcs-snapshot wxwidgets
  6. DESCRIPTION="Visualization and Audibilization of Sorting Algorithms"
  7. HOMEPAGE="http://panthema.net/2013/sound-of-sorting/ https://github.com/bingmann/sound-of-sorting"
  8. #SRC_URI="http://panthema.net/2013/sound-of-sorting/${P}.tar.bz2"
  9. COMMIT="05db428c796a7006d63efdbe314f976e0aa881d6"
  10. SRC_URI="https://github.com/bingmann/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
  11. LICENSE="GPL-3"
  12. SLOT="0"
  13. KEYWORDS="~amd64"
  14. IUSE=""
  15. RDEPEND="
  16. media-libs/libsdl
  17. x11-libs/wxGTK:${WX_GTK_VER}
  18. "
  19. DEPEND="${RDEPEND}"
  20. src_unpack() {
  21. vcs-snapshot_src_unpack
  22. need-wxwidgets unicode
  23. }