gnome-mud-0.11.2-r1.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. GNOME_TARBALL_SUFFIX="bz2"
  5. inherit gnome2
  6. DESCRIPTION="GNOME MUD client"
  7. HOMEPAGE="https://wiki.gnome.org/Apps/GnomeMud"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
  11. IUSE="gstreamer"
  12. RDEPEND="virtual/libintl
  13. dev-libs/libpcre
  14. dev-perl/XML-Parser
  15. gnome-base/gconf:2
  16. >=gnome-base/libglade-2.0.1:2.0
  17. gstreamer? ( media-libs/gstreamer:0.10 )
  18. net-libs/gnet:2
  19. x11-libs/gtk+:2
  20. >=x11-libs/vte-0.11:0"
  21. DEPEND="${RDEPEND}
  22. virtual/pkgconfig
  23. app-text/rarian
  24. >=dev-util/intltool-0.23
  25. >=sys-devel/gettext-0.11.5"
  26. src_configure() {
  27. gnome2_src_configure \
  28. $(use_enable gstreamer)
  29. }
  30. src_install() {
  31. DOCS="AUTHORS BUGS ChangeLog NEWS PLUGIN.API README ROADMAP" \
  32. gnome2_src_install
  33. }
  34. pkg_preinst() {
  35. gnome2_pkg_preinst
  36. }
  37. pkg_postinst() {
  38. gnome2_pkg_postinst
  39. echo
  40. elog "For proper plugin operation, please create ~/.gnome-mud/plugins/"
  41. elog "if that directory doesn't already exist."
  42. elog "The command to do that is:"
  43. elog " mkdir -p ~/.gnome-mud/plugins/"
  44. echo
  45. }