mudix-4.3-r2.ebuild 532 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="A small, stable MUD client for the console"
  5. HOMEPAGE="http://dw.nl.eu.org/mudix.html"
  6. SRC_URI="http://dw.nl.eu.org/mudix/${P}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~ppc ~x86"
  10. IUSE=""
  11. DEPEND="sys-libs/ncurses:0"
  12. RDEPEND=${DEPEND}
  13. PATCHES=(
  14. "${FILESDIR}"/${P}-as-needed.patch
  15. )
  16. src_compile() {
  17. emake -C src O_FLAGS="${CFLAGS}"
  18. }
  19. src_install () {
  20. dobin mudix
  21. dodoc README sample.usr
  22. }