braincurses-0.5b.ebuild 698 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils games
  5. DESCRIPTION="An ncurses-based mastermind clone"
  6. HOMEPAGE="http://freshmeat.net/projects/braincurses/"
  7. SRC_URI="mirror://sourceforge/braincurses/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~ppc ppc64 x86"
  11. IUSE=""
  12. DEPEND=""
  13. RDEPEND=""
  14. src_prepare() {
  15. epatch "${FILESDIR}"/${P}-gcc43.patch \
  16. "${FILESDIR}"/${P}-as-needed.patch
  17. # fix buffer overflow (bug #301033)
  18. sed -i \
  19. -e 's/guessLabel\[2/guessLabel[3/' \
  20. curses/windows.cpp \
  21. || die 'sed failed'
  22. }
  23. src_install() {
  24. dogamesbin braincurses
  25. dodoc README THANKS Changelog
  26. prepgamesdirs
  27. }